¿Cómo Activar PHP 5.3 en HostGator?

Uno de los problemas que se presentan a la hora de instalar aplicaciones que requieren PHP 5.3 en Hostgator es que se encuentran con que la versión instalada por defecto (al menos hasta el día de hoy) es la 5.2.17.

Entonces cuando queremos instalar Moodle en sus últimas versiones (por dar un ejemplo práctico), nos encontramos con un mensaje de error reclamando que requiere PHP 5.3 o superior cuando tenemos una versión inferior a esta como es en el caso de HG con su versión por defecto 5.2.17.

Cabe destacar que los Windows Shared & Chilisoft ASP no tienen disponible PHP 5.3 (al menos hasta el día de hoy).

Entonces… ¿Cómo Activar PHP 5.3 en HostGator?

Lo cierto es los servidores de Hostgator que vienen por defecto con la 5.2, también soportan PHP 5.3, sólo que hay que “activarlo”. Para esto, debemos actuar de acuerdo al servicio que tangamos contratado:

1) Shared Hosting y Reseller

Para activar, debes descargar el el fichero .htaccess del directorio está nuestra aplicación que requiere PHP 5.3.

Luego abrir el .htaccess (con una aplicación acorde) y debes ingresar las siguientes líneas:

# Use PHP 5.3
AddType application/x-httpd-php53 .php

Modificado, lo guardas y vuelves a subir mediante FTP, FileManager o SSH.

Con esto sería suficiente.

2) VPS y Servidores Dedicados

En el caso de estos, para activar esta versión de PHP, el proceso es enviar un correo a [email protected] o bien abrir un ticket de soporte solicitando esto y explicando su necesidad.

PHP.INI

Si utilizas un archivo php.ini personalizado que hace referencia a los módulos PHP que no están disponibles con PHP 5.3, tendrás problemas de funcionamiento. Es recomendado eliminar el archivo php.ini personalizado (que hará que el servidor utilice el archivo php.ini por defecto para PHP 5.3), o crear un archivo php.ini compatible con PHP 5.3.

Espero que te haya servido esta información y si deseas contratar HostGator, TE REGALO UN CUPON DE 25% DE DESCUENTO! el cual puedes aplicar al momento de contratar en la web de HostGator haciendo CLICK AQUI

Cupón: BETTERBLOG

Artículo: ¿Cómo Activar PHP 5.3 en HostGator?

4 Comentarios

  • This release resolves a critical issue, reported as PHP bug #53632, where conversions from string to double might cause the PHP interpreter to hang on systems using x87 FPU registers.

  • Muchas gracias por este articulo, justo lo que estaba buscando. Me acabo de mudar a hostgator con el plan baby y mi web joomla estaba teniendo problemas y me di cuenta que el foro kunena que tenia instalado requeria de una version mayor de php de la que venia por defecto, estaba pensando en contactarme para ver si me pasaban a otro hosting con ese requerimiento o si volvia a una version anterior de kunena donde soportaba el php que tenia por defecto. Felizmente encontre tu articulo y pude aplicar este cambio al htaccess para activar una version mayor de php y logre solucionar mi problema, nuevamente muchas gracias.

    • Estimado Richard

      Me alegra mucho que te haya sido de utilidad el artículo. Un gran y cordial abrazo a la distancia y muchas gracias por tu review!

      Saludos cordiales!

Únete a la discusión

Puedes usar las siguientes HTML etiquetas y atributos: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>